{mdm}Script 4.0 API